Home LibAPMath Animath Anipool
Top Version 1.2 Version 1.1 Version 1.0 Version < 1.0 Support

APMath logo

Welcome to the homepage of the APMath-project. Aim of this project is the implementation of an arbitrary precision C++-library, that is the most convenient in use, this means all operations are implemented as operator-overloadings, naming is mostly the same as that of <cmath>.

Library Documentation
get the latest stable version

Version 1.2

version link dependencies release date
yyyy/mm/dd
Changelog
1.2 libapmath-1.2.tar.gz
  1. GNU libstdc++6 4.0
  2. GNU Make 3.81 or newer
  3. GNU G++ 4.0 or newer.
  4. libcwd 1.00 or newer (optional).
  5. CppTest 1.1 or newer (optional).
  6. libmpich 1.0 or newer.
2008/08/30 Changelog-1.2

Example Applications

Version 1.1

version link dependencies release date
yyyy/mm/dd
Changelog
1.1 libapmath-1.1.tar.gz
  1. GNU libstdc++6 4.0
  2. GNU Make 3.81 or newer
  3. GNU G++ 4.0 or newer.
  4. libcwd 1.00 or newer (optional).
  5. CppTest 1.1 or newer (optional).
  6. libmpich 1.0 or newer.
2008/07/21 Changelog-1.1

StackApCalc for APMath 1.1

This is a simple example application that uses LibAPMath. It is an HP-type stack calculator that features complex arithmetic.

Download

Version 1.0

version link dependencies release date
yyyy/mm/dd
Changelog
1.0.0 libapmath-1.0.0.tgz
  1. GNU libstdc++6 4.0
  2. GNU Make 3.81 or newer
  3. GNU G++ 4.0 or newer.
  4. libcwd 1.00 or newer (optional).
  5. libmpich 1.0 or newer.
2008/06/29 Changelog-1.0.0

StackApCalc for APMath 1.0

This is a simple example application that uses LibAPMath. It is an HP-type stack calculator that features complex arithmetic.

Download

Version 0.5 and Earlier

version link dependencies release date
yyyy/mm/dd
Changelog
0.5.0 libapmath-0.5.0.tgz
  1. GNU libstdc++6 4.0
  2. GNU G++ 4.0 or newer.
  3. libcwd 1.00 or newer.
2008/02/20 Changelog-0.5.0
0.4.2 libapmath-0.4.2.tgz
  1. GNU libstdc++6 4.0
  2. GNU G++ 4.0 or newer.
  3. libcwd 0.99 or newer.
2007/10/06
0.4.1 libapmath-0.4.1.tgz
  1. GNU libstdc++6 4.0
  2. GNU G++ 4.0 or newer.
  3. libcwd 0.99 or newer.
2007/09/23
0.4 libapmath-0.4.tgz
  1. GNU libstdc++6 4.0
  2. GNU G++ 4.0 or newer.
  3. libcwd 0.99 or newer.
2007/09/15

StackApCalc for APMath 0.x

This is a simple example application that uses LibAPMath. It is an HP-type stack calculator that features complex arithmetic.

Download

Contact

For bug reports, feature requests and general inquiries, please send an e-mail to software-AT-yonsen.bz.

Donations

If you like my work, please support me with a donation, such that I also in future can devote a great share of my time to this project.